SiteCTMS - Slowness and intermittent errors

Incident Report for SignalPath

Resolved

This incident has been resolved.
Posted Aug 18, 2026 - 10:20 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 17, 2026 - 15:51 EDT

Investigating

Some users may experience slowness and intermittent error messages within Enterprise and TrialPath. Our team is currently working to resolve the issue. We apologize for the inconvenience and will provide updates via the status page.
Posted Aug 17, 2026 - 10:35 EDT
This incident affected: SignalPath Application Suite (TrialPath).