Site CTMS Outage

Incident Report for SignalPath

Resolved

The application is back up and running, we will continue to monitor for issues.
Posted Sep 24, 2024 - 21:00 EDT

Identified

The issue has been identified and the team is working to apply a fix to restore functionality of the application suite.
Posted Sep 24, 2024 - 20:53 EDT

Investigating

Current the CTMS application is experiencing a major outage, we are actively investigating the cause and working to resolve the issue as soon as possible
Posted Sep 24, 2024 - 20:46 EDT
This incident affected: SignalPath Application Suite (API, TrialPath, Insights).