SiteCTMS Application Suite: Major Outage

Incident Report for SignalPath

Resolved

The SiteCTMS application suite has been fully restored. The on-call team will continue monitor the status of the application.
Posted Apr 23, 2025 - 18:19 EDT

Identified

SiteCTMS has identified the issue and is working on bringing the application back online fully. The on-call team will continue to provide updates and monitor the system as services become available
Posted Apr 23, 2025 - 17:40 EDT

Update

The CTMS team is still investigating the system outage. The team will continue to post updates as they come up.
Posted Apr 23, 2025 - 15:55 EDT

Investigating

Currently the SiteCTMS Application is experiencing a total outage. The on-call team is investigating and will post updates as more information comes up
Posted Apr 23, 2025 - 14:39 EDT
This incident affected: SignalPath Application Suite (API, TrialPath, Insights).