SiteCTMS Partial System Outage - Finance

Incident Report for SignalPath

Resolved

This incident has been resolved.
Posted Jan 15, 2026 - 20:03 EST

Monitoring

A fix for the issue has been deployed and tested, and normal application functionality has been restored. We will continue to monitor the application state with the fix in place.
Posted Jan 15, 2026 - 17:45 EST

Identified

We have identified the source of the issue and are testing a fix. We thank you for your patience and will continue to provide updates via the status page
Posted Jan 15, 2026 - 15:55 EST

Investigating

Some users may experience a service outage with Finance. Our team is currently working to restore the service. We apologize for the inconvenience and will provide updates via the status page.
Posted Jan 15, 2026 - 12:45 EST
This incident affected: SignalPath Application Suite (TrialPath).