Degredated performance of trialpath

Incident Report for SignalPath

Resolved

Incident was resolved
Posted Oct 07, 2024 - 09:10 EDT

Investigating

We are currently investigating a slowness of actions moving from trialpath to other parts of the applciation
Posted Oct 04, 2024 - 14:14 EDT
This incident affected: SignalPath Application Suite (TrialPath).